Monday, 19 September 2016

Reasons to Upgrade Your WiFi


Reasons to Upgrade a Wireless Network (WiFi)

I was recently asked by a businessman to write him up a brief report on why he should upgrade his wireless network? So what are the reasons? This report might be handy for you.


A wireless local area network is a computer network that links two or more devices using a wireless distribution method within a limited area.”

This simple report covers some of the key concepts and ideas to consider, focused on wireless local area network upgrades. It is divided into three key areas of impact, technological, business and security.

Technological Impact:

Before defining the reasons in favour of a WiFi upgrade, it would be pertinent to have a basic understanding of the underlying technology that facilitates the operation of wireless networks.
WiFi has a changing set of standards, which are defined by the Institute of Electrical and Electronics Engineers (IEEE), WiFi is based on the IEEE802.11x standard, where x is the name given to the particular version being used. These standards improve every few years, consider the following table which looks at the evolution of IEE802.11. The protocol name is given along with the release date, range in metres and the maximum data rate (the data rate can be considered a benchmark of how fast the WiFi will work, in real terms how much data can be uploaded and downloaded from the network per second.) This rate is measured in millions of bits per second (mega bits per second Mbit/s).

IEE802.11 Protocol
Release Date
Data Rate (Mbit/s)
Metres Range Indoor Approx.
802.11b
1999
11
35
802.11g
2003
54
38
802.11n
2009
135
70
802.11ac
2013
180
35
802.11ay
Proposed for 2017
100,000
60

As each of these standards has evolved, so too has the ability of wireless technology to reach through walls and into confined spaces. The data presented in the above table would show a clear technological advantage to upgrading a wireless technology.

Business Impact:

Many businesses now offer free WiFi to customers, in a recent article by the Business and technology News Website, published this May, several reasons are given. You will enhance your marketing – by setting a business name e.g. Sally's Best Cupcakes Free WiFi you can broadcast your business name to user devices. Business class WiFi solutions also allow for the creation of a custom splash or landing page which can contain information about your latest offers which the customer will see when they connect. Customers can also do some marketing for you by “checking in” at your location.

Customers are likely to spend more time at your place of business, in fact 62% of businesses report that customers spend more time in their facility when WiFi is available. Many people also filter businesses on which ones offer free WiFi, If people can access their work emails and use their laptops and tables at your location you will gain a competitive edge over rivals. In a recent local search of Tripadvisor, enter the words (bad or poor WiFi) and have a look at what consumers have said about local businesses.
Security Impact:

Information security is a concern in a digital age, if your customers are making online purchases, doing online banking or sending confidential information over email, it would be important to have a secure network. Your internet service provider will have provided you with a simple Wireless device which has some basic security features, however many of these are easily broken into. Data interception, password cracking and network intrusion are all considerations. A business class WiFi network will allow the creation of a segregated public WiFi network (a walled garden). Which will provide enhanced security to users. Your own computer systems may also be connected to the same network as your customers, in a properly constructed network these should and can be segregated.

The following Illustrations show how a guest network can be separated from a staff network for the purposes of information security, and network management. In illustration 1 we can see a network in which everyone shares the same local area connection to the network, and in illustration 2 we can see a more secure and organised network architecture.


Illustration 1: Basic Network


In illustration 1 all the clients are connected to the same router, this will provide limited WiFi range and will also provide an intruder with an easier task of accessing the other members of the network.

Illustration 2: More Secure Network
In illustration 2 we can see the logical segregation of networks, providing more security to both customers and staff and improved wireless coverage.

Huge Project On HSRP & GLBP



For my honours project I did a very extensive study on optimising HSRP & GLBP for fastest recovery from link failure. If you are looking to adjust the metrics for this protocols and/or ensure fastest operational times then you should probably have a look at this. I will post a link to the PDF below, however here are some out-takes:

 

 


















PC Basic Configuration

PC(config)# no ip routing
PC(config)# ip default-gateway 10.1.1.1
PC(config)# interface fastEthernet 0/0
PC(config-if)# ip address 10.1.1.175 255.255.255.0
PC(config-if)# no shutdown


INTERNET Basic Configuration

INTERNET(config)# interface fastEthernet 0/0
INTERNET(config-if)# ip address 10.2.2.3 255.255.255.0
INTERNET(config-if)# no shutdown
INTERNET(config-if)# interface loopback 1
INTERNET(config-if)# ip address 8.8.8.8 255.255.255.255
INTERNET(config-if)# no shutdown
INTERNET(config)# router eigrp 1
INTERNET(config-router)# network 10.2.2.3 0.0.0.0
INTERNET(config-router)# network 8.8.8.8 0.0.0.0

R1 Basic Configuration

R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 10.1.1.3 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface fa0/1
R1(config-if)# ip address 10.2.2.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# router eigrp 1
R1(config-router)# network 10.2.2.1 0.0.0.0
R1(config-router)# network 10.1.1.0 0.0.0.255
R1(config)#int fastEthernet 0/0
R1(config-if)#standby 1 ip 10.1.1.1

R2 Basic Configuration

R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 10.1.1.2 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface fa0/1
R1(config-if)# ip address 10.2.2.2 255.255.255.0
R1(config-if)# no shutdown
R1(config)# router eigrp 1
R1(config-router)# network 10.2.2.1 0.0.0.0
R1(config-router)# network 10.1.1.0 0.0.0.255
R1(config)#int fastEthernet 0/0
R1(config-if)#standby 1 ip 10.1.1.1

Now that the devices are configured each of the configurations are verified with show commands to ensure that routing can take place between the devices.

PC#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.175 YES manual up up

INTERNET#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.2.2.3 YES manual up up
Loopback1 8.8.8.8 YES manual up up

R1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.3 YES manual up up
FastEthernet0/1 10.2.2.1 YES manual up up

R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.1.1.2 YES manual up up
FastEthernet0/1 10.2.2.2 YES manual up up


Now that the IP addressing is in place, 'show eigrp' the 'show eigrp' command verifies the dynamic routing between R1, R2 and the INTERNET routers.


R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.2.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 8.0.0.0/8, 1 successors, FD is 156160
via 10.2.2.3 (156160/128256), FastEthernet0/1
P 10.1.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 10.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 8.0.0.0/8, 1 successors, FD is 156160
via 10.2.2.3 (156160/128256), FastEthernet0/1
P 10.1.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 10.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1

INTERNET#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(8.8.8.8)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 8.8.8.8/32, 1 successors, FD is 128256
via Connected, Loopback1
P 8.0.0.0/8, 1 successors, FD is 128256
via Summary (128256/0), Null0
P 10.1.1.0/24, 2 successors, FD is 30720
via 10.2.2.2 (30720/28160), FastEthernet0/0
via 10.2.2.1 (30720/28160), FastEthernet0/0
P 10.0.0.0/8, 1 successors, FD is 28160
via Summary (28160/0), Null0
P 10.2.2.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0

Now that routing and addressing is verified the show standby command is issued on R1 and R2 in order to view the virtual IP and MAC address which will be used in this HSRP instance, we can also see that pre-emption is off and the active router, due to having the highest physical address won the election, with R2 on hot standby both routers have a default pre-emption state of disabled and also both have the default priority of 1, they are now fully configured with HSRP.

R1#show standby
FastEthernet0/0 - Group 1
State is Active
17 state changes, last state change 00:21:50
Virtual IP address is 10.1.1.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.868 secs
Preemption disabled
Active router is local
Standby router is 10.1.1.2, priority 100 (expires in 7.008 sec)
Priority 100 (default 100)
IP redundancy name is "hsrp-Fa0/0-1" (default)


R2#show standby
FastEthernet0/0 - Group 1
State is Standby
18 state changes, last state change 00:20:39
Virtual IP address is 10.1.1.1
Active virtual MAC address is 0000.0c07.ac01
Local virtual MAC address is 0000.0c07.ac01 (default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.488 secs
Preemption disabled
Active router is 10.1.1.3, priority 100 (expires in 7.360 sec)
Standby router is local
Priority 100 (default 100)
IP redundancy name is "hsrp-Fa0/0-1" (default)


In order to verify this HSRP instance the IOS extended ping command is used to send a large number of ICMP datagrams, while these send repeatedly the active routers FasEthernet 0/0 interface will be shutdown to demonstrate HSRP providing redundancy by enabling the standby router at the point of the active router shutting down. Key points in the output are highlighted in bold where the R1 or R2 interface is shutdown a full output is also shown in Appendix 4 which shows the full visual output from the IOS as an example. From the output shown below it can be seen that 4 ICMP packets are dropped before HSRP makes the standby router take over upon failure of the active router. The 3rd instance of the ping failing happens to last for 8 packets, the reason here is because both routers were taken down, and the standby router enabled, links failing are shown in bold, links coming to the Up and Active state are also shown in bold and the 8 ping failure is also highlighted in bold, where HSRP has to promote the standby router to active. Here is the output from R1 with the FastEthernet 0/0 interface being shutdown, then started again with the no shutdown command, we can see the HSRP state. Although the EIGRP output has been removed to reduce the size and detail of this project, the DUAL finite state machine is also forming adjacencies each time the interface comes back up.
R1(config-if)#shutdown
*Mar 1 00:44:44.527: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Init
*Mar 1 00:44:46.527: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down

R1(config-if)#no shutdown
*Mar 1 00:46:20.055: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:46:21.055: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Mar 1 00:46:39.055: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active
R1(config-if)#shutdown
*Mar 1 00:47:13.511: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Init

*Mar 1 00:47:15.511: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down


On router R2 I also took down the FastEthernet interface, to force HSRP to change the state of R2 from standby to active, here we can see the status of the HSRP protocol changing on R2.


R2(config-if)#shutdown
*Mar 1 00:43:34.691: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Init
*Mar 1 00:43:36.691: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Mar 1 00:43:37.691: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down

R2(config-if)#no shutdown
*Mar 1 00:44:33.875: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:44:34.875: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#
*Mar 1 00:44:54.291: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

R2(config-if)#shutdown
*Mar 1 00:46:02.931: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Init
*Mar 1 00:46:04.931: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Mar 1 00:46:05.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down


R2(config-if)#no shutdown
*Mar 1 00:46:46.547: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:46:47.547: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#
*Mar 1 00:47:13.735: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active



R2(config-if)#shutdown
*Mar 1 00:47:44.139: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Init
*Mar 1 00:47:46.139: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Mar 1 00:47:47.139: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down


R2(config-if)#no shutdown
*Mar 1 00:48:03.051: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:48:04.051: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
*Mar 1 00:48:39.767: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby -> Active

It basically goes on like this for 150 pages, examining each of the protocols in great detail. Then gets into graphs in comaprison:

 You can download the full study from here: